MetaTrader Compatibility Issue with Latest Update MacOS Catalina

Dear Trader,

This message only concerns those who are using MetaTrader for Mac for trading.

Unfortunately, the latest update for Mac OS – Catalina, introduced a compatibility issue that does not allow MetaTrader programs to run and currently no longer function on the platform works. We recommend our MacOS-based users who wish to continue trading on their Mac platform to postpone the update until a fix is available on web.

In the meanwhile, such affected users can continue to trade  install Windows onto their Mac systems as a second OS, or to use within virtualization software like Parallels Desktop.

All traders who utilise the PC or Windows platform are not affected with this update, and can continue trading without any concern.

If you have further questions regarding this issue, please contact our customer service.

Kind regards,

Cabana Capitals

 

MetaTrader Compatibility Issue with Latest Update MacOS Catalina



Leave a Reply

%d bloggers like this: